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ServoCommander Main Screen
The Endurance R/C ServoCommander software was designed to allow input devices like head trackers, mice, keyboards, and joysticks to control standard R/C equipment like servos, motors, and transmitters. When used with the PCTx, 25 Servo Controller, or WiFi Servo Controller the software allows joystick axes, buttons, sliders, and dials to be mapped to R/C servos and motor controllers. Anything that can be attached to an R/C receiver or servo controller can be configured and controlled with ServoCommander. The software supports all windows joysticks and input devices including game pads, joysticks, game wheels as well as the z800 headset and mouse. There is even a web interface that can be used to control a remote device over the internet!
The server software is open source and can be downloaded from the software development section: http://www.endurance-rc.com/software.html
The eMagin Z800 headset with built in head tracking can be used as an input device. Usage of the AeroPix head tracker is also possible when using the pass through functionality of the head tracker.
Important Note about the Z800 headset:

This software is not compatible with eMagin Z800 firmware version 63e or earlier. You can check your firmware version in the eMagin control panel software. If you have this version an update chip can be obtained from eMagin’s web store for $25.00usd.

Requirements:
PCTx, HRPCTx, Endurance R/C 25 Servo Controller or the WiFi Servo Controller
Input Device – Such as a Joystick, Game pad, Analog Reader or mouse
PC running Windows XP, Vista, Windows 7
Remote - 2 PC's and internet connection for web interface
 Index

	Output Device Setup
	4

	PCTx and HRPCTx
	5

	R/C Transmitter
	6

	25 Servo Controller
	7

	WiFi Servo Controller
	8

	Input Device Setup
	9

	Joystick 
	10

	           Keyboard 
	12

	Mouse 
	13

	eMagin Z800
	14

	           Centering the Headset
	15

	           Analog Reader and Analog Reader 2
	16

	ServoCommander Setup
	17

	End and Mid points
	18

	Mixing and multiple channel output
	19

	Tank Control
	20

	           Profiles
	21

	Sensitivity
	22

	Inverting
	23

	
Delay
	24

	           Web Setup
	25

	           Web connection troubleshooting
	26

	           Running ServoCommander
	27

	           Custom Tab Names
	28

	           Reverse at mid
	29

	           Hide Label
	30

	           Wide View
	31

	           Exponential Settings                                                                          
	32

	
	

	
	

	
	

	
	

	
	

	
	

	
	

	
	

	
	

	
	

	
	

	
	

	
	

	
	

	
	

	
	

	
	


Output Device Setup

ServoCommander is compatible with the Endurance R/C PCTx, 25 Servo Controller, and WiFi Servo Controller only. Devices from other manufacturers are not compatible with the software. Output devices can be plugged into ServoCommander at any time. The software will automatically configure itself for the type of output device connected.
PCTx/HRPCTx
1. Plug the PCTx or HRPCTx interface into an open powered USB port and then into your transmitter’s trainer port. Windows will recognize the device and automatically install the correct drivers.

2. Windows will display a message indicating the PCTx was installed correctly. If a problem occurs with the install unplug the PCTx and re-insert.

3. If you are unsure if the PCTx was correctly installed you can open the device manager to check. From the windows desktop or start menu click on My Computer and choose Properties. Go to the hardware tab and press the Device Manager button. Expand the “Human Interface Devices” section. When you plug in the PCTx a “HID-compliant device” and a “USB Human Interface Device” will appear.

4. During the operation of ServoCommander a green box will indicate that a PCTx is present on the system and “PCTx” will display as the connected output device.
5. Set the resolution accordingly. PCTx = 256, HRPCTx = 1024
R/C Transmitter


1. Make sure the trainer switch on the transmitter is switched to the OFF position. If your radio was purchased from Endurance R/C a toggle switch has been installed in the transmitter which allows for on/off trainer action. If you did not purchase your radio system from Endurance R/C the momentary toggle switch must be held down, replaced with a toggle, or removed and re-wired in order to achieve hands off trainer functions.
2. Extend the transmitter antenna, power on the transmitter, and then power on the model or robot. Slowly move the control sticks to verify all functions are working correctly.
3. If your radio requires and special setup to enable trainer input do this now.

4. Plug the PCTx into the transmitter’s trainer port.


25 Servo Controller


1. Plug the 25 Servo Controller to an open powered USB port. Windows will recognize the device and automatically install the correct drivers.

2. Windows will display a message indicating the controller was installed correctly. If a problem occurs with the install unplug the controller and re-insert.

3. If you are unsure if the controller was correctly installed you can open the device manager to check. From the windows desktop or start menu click on My Computer and choose Properties. Go to the hardware tab and press the Device Manager button. Expand the “Human Interface Devices” section. When you plug in the PCTx a “HID-compliant device” and a “USB Human Interface Device” will appear.

4. An external power source is required for powering the 25 Servo Controller. Standard servos usually require a power source of 5v-6v DC. Some servos will run on 9v and above as well. The 25 Servo Controller was designed to work with any servo and subsequent power source. Power for the controller and servos are isolated. Please consult the servo manufacturer instructions for selection the proper power source for your servo.

5. Connect the power source to the terminal next to the USB connector. Insert the positive line into the side of the connector marked with the ‘+’ symbol, next to the status indicator.


6. During the operation of ServoCommander a green box will indicate that a controller is present on the system and “25 Servo Controller” will display as the connected output device.
WiFi Servo Controller


1. In order to use the WiFi Servo Controller with ServoCommander a virtual COM port must be setup on the PC running ServoCommander. Please follow the WiFi Servo Controller directions on installing the Lantronix CPR software. Once the CPR software has been installed and configured and new virtual COM port will be installed. This will map all traffic sent to this port to the WiFi Servo Controller.

2. In order to tell ServoCommander to send data to the virtual port choose “Local Serial” in the output device location drop down menu. A new drop down menu will appear to the right of this menu. Choose the proper port that was configured with the CPR software.
Input Device Setup
Go to Input Edit->Settings. The Input Settings will be displayed. The following is an image of the Joystick setup dialog. Each tab will display settings for the appropriate device.
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Joystick setup screen
Joystick
1. Click on the Joystick tab to reveal the joystick setup screen. If a joystick has not been detected channel selection drop down menus will be disabled.
2. Move the joystick or press any available buttons to see how the software responds to the movement. Button presses will display a green box next to the appropriate button. Axes, sliders, and dials will display a value from 0-255. 

3. Once you have located the function you wish to map select the correct output channel from the corresponding list. The channels chosen here will take on the settings applied for the corresponding channel settings on the main screen.


4. Repeat until all channels are set. Red boxes next to each channel will indicate a duplicate setting which will prevent the settings from being saved. Remove any duplicates by selecting a free channel or press the Clear All Settings button to reset all settings.
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Duplicate channel assignments
5. If you wish to give custom names to each Joystick functions you can do this now by editing the text in the box next to the channel pull down menus. These names will be saved/loaded in the profile data. It is recommended to give each channel a custom name for ease in use.


6. Once the joystick is setup click Save.


7. Move the joystick axes and buttons to their default positions and press the “Set All Centers” button. If you are using a complicated joystick and are unable to find the centers at this time you can easily come back and reset the center values individually by pressing the “Set Center” button for the corresponding axis.  Buttons do not require center values to be set. 


8. To setup a second joystick click the Joystick 2 tab and start again at step 2.
Keyboard
You can assign up to 5 channels to keys on the keyboard.
1. Click on the Keyboard tab to reveal the keyboard setup.
2. Press any available key. The last key press will display a unique code corresponding to that key.

3. Press the “Set to Last” button next to one of the 5 available slots to map the key.

4. Set the channel drop down menu to map the key to an output channel.

5. Give the key a name in the text box to the left of the channel menu if you wish.
Mouse

ServoCommander can also take advantage of mouse buttons and mouse position on the screen.

1. Click on the Mouse tab to reveal the mouse setup.


2. Clicking on the left and right mouse buttons will be displayed here as well as the mouse coordinates.

3. Assign these functions by selecting an available channel.
eMagin Z800
Note: The following is not required if you choose to not use the z800 headset

1. Insert the z800 3DVisor Software Utility CD and install the eMagin support software. Plug the headset into an open USB port and test the headset motion sensor using the utility before moving forward.

2. Connect the desired video source to the composite video input on the AV Tool video converter. The composite to VGA converter is required to convert the video signal into the VGA signal that the z800 accepts.

3. Connect the VGA output of the AV Tool converter to the input VGA on the eMagin control box (this is the VGA port directly next to the microphone input.)


4. Connect the composite video output from your camera source to the composite input on the AV Tool converter.


5. Test the video feed on the headset before moving forward.


Note: The AV Tool converter needs to be setup to output a signal that the video goggles can display. If the goggles do not display and image make sure the led on the eMagin control box is green and the AV Tool converter is on. If you still only see a black image perform the following steps.


1. Press the menu button on the AV Tool

2. Go to Output Setup

3. Then Set to SGA

4. Also make sure that the input is set to C-Video
Centering the Headset
Due to the nature of the head tracking sensors, drift in the center points will occur over time. In order to reset the system press the center button on the main screen. This will return the camera to the center position that you set during ServoCommander setup. When you release the buttons the center point of the headset will also be reset to its current position; look forward in a natural position while holding down the center button.
If you are using a joystick, the headset can also be centered by button presses. Under the Input device settings choose the desired button, press and hold. Wherever the green box appears, select “Center HMD” from the drop down menu to map the center function to the particular button.

Analog Reader and Analog Reader 2
ServoCommander will see the analog reader inputs as a Direct Input joystick. Setup for the Analog Reader and Analog Reader 2 are the same as a standard joystick. See page 9 for joystick setup instructions.

 ServoCommander Setup
1. Place the ServoCommander CD in your PC and follow the setup instructions.


2. Double click the ServoCommander shortcut. If any errors occur while starting run setup again and be sure to install all supporting files and restart your computer.

3. Make sure all devices are powered on and connected before starting the software. Each device will appear with green boxes next to the name if the device is present. Red boxes will indicate the device is unavailable to the ServoCommander software. If the device is connected to the PC after the ServoCommander software has been started the application must be re-started in order to recognize the device.



[image: image5.jpg][E servoCommander
Ble Edt Help

[_[C1x]

Chareel7 | Chameld | Chamels | Chamel10 | Chamel 11 | Chamel 12 | Charnel 13
Chareel 14 | Charnel15 | Charnel 15 | Charnel17 | Charnel 18 | Charnel s | Channel2n
Charmel21 Charnel 22 Charelzs | Chamel2t | Chammelzs
Chamel1 | chamelz | Chawels | Chamweld | Chomels | Chamels
~SenvoSeltngs Edit Tab Name

Leh EndPoint Certer Fight End Poirt
44 150 233
] i} i

Set Set St
I vt Reset Reverse AtMid CurentPosten

145

Sensiiviy
Less More
i o 2l I~ HoldOnkey n
~SenvoDely 5
More. Less —
7l T3 i i Setings

Server Settings

Pot [
P

Comeet_|| | Dicomest

Status: Not Comnected

Output Device: Ml PLTx
Device Resoluion 256 -

Output Device Localion [LocalUSE v

Jopstck: [IE Headser Wl

Profle:  testere

Start Siop Certe Headset





ServoCommander on startup
End and Mid points
End-point and center point values that have not been set will appear in red. The mid points and end points for each channel must be set before communication to the transmitter (PCTx) or 25 Servo Controller will begin. Assigning these values is important in preventing a servo from moving past its maximum travel positions and in turn damaging the servo or the model as well as preventing an electronic speed control and motor from spinning faster than needed. The values can be set by pressing the set button corresponding to left, right, and middle positions. The text will change and appear black when set. All 9 (PCTx) or 25 channels (25 Servo Controller) must be set in order to start the communication with the model.
Note: To save setup time in the future you can save and load profiles by going to File -> Save. Saved settings can also be loaded from the File menu.

Mixing and Multiple Channel Output
The ServoCommander software also allows the setting of multiple servo/ESC outputs for the same line of control. Servos/ESC’s can also be set for rotation direction and delay independently to provide mixing features most commonly used in R/C planes and helicopters. Multiple channels can be set by clicking the Mix Settings button under each channel tab. The current channel will show up as disabled. Checking any of the 24 boxes will set the same line of control to the selected channel.
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Mix Settings
A mixed channel will retain the settings found it its tab on the main screen. Inverting, delay, and mid/end points will still be applied to that channel only. Using these settings the user can select the proper movement that is required for the particular use. Mixing will only be applied when the software has been started.
For example, to set aileron channels for an airplane, channels 1 and 2 could be mixed together. The channel that is mixed with the other does not matter just as long as the opposite settings are applied to each channel. If channel 1 was mixed with channel 2, channel 2’s movement should be set as inverted while channel one set to normal creating opposite servo movement for each wing.

Tank Control
The Tank Control feature allows for one to setup a joystick to operate a robot or tank naturally. To setup Tank Control have a previously setup joystick or input device
1. Identify an axis control to be assigned to the throttle and steering controls. A joystick axis or mouse will work fine for this. Something like a button without a full range of control will not work correctly.


2. Open the Tank Control dialog from the Edit menu.


3. Assign the throttle and steering channels as well as the number of powered wheels.
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ServoCommander Tank Control Settings
4. Move the dead zone sliders if desired. The dead zone will create an area where joystick movement is disabled which allows the user greater control of the tank or robot.

5. If desired the dialog can be left open to view tank setting data while running.
Profiles

User profiles can be saved and loaded from the File menu. All user settings will be saved in this file to allow for quick loading in the future.

Multiple profiles complete with different model setting data and input device data can be saved and imported in seconds.
The file saved will include an .erc extension however the file is plain text and can be edited outside of ServoCommander with a text editor if desired however values and their positions are not published at this time.

Sensitivity
Channel sensitivity should not be confused with channel delay. While channel delay will slow down the actual movement of the servo, the sensitivity setting will allow a joystick axis for example to be moved in a much further direction to achieve the same movement. Again, move the slider bar on the corresponding channel to set the sensitivity. Sensitivity can be adjusted from 1-500% of the current value.
Inverting
If the servo needs to be reversed you can set its direction by checking the “Invert” option on the corresponding channel tab. If the channel is set to a joystick or mouse button you will notice the servo change from one end-point to the other immediately after inverting. Axes, dials, sliders, mouse positions will reverse direction from the center point value. Inverting options can be set while ServoCommander is sending data to the transmitter or servo controller for on-the-fly adjustments. 

Delay

A delay effect can be set for each channel by moving the delay slider on each channel. This will allow servo motion to be slowed down or ESC throttle action to be delayed for such items as landing gear. Move the slider bar on the corresponding channel to set the delay.

Web Setup
1. The ServoCommander software allows data to be sent to a remote PC running the Server software. A PCTx or 25 Servo Controller must be connected to the remote PC. The Server software is open source and can be downloaded from www.endurance-rc.com/software.html
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Server
2. After the server has been started, start ServoCommander and load a saved profile or enter new end and mid point settings. For the “Output Device Location” select “Remote” from the location combo box. Under the IP setting, enter the IP displayed on the server application and click connect. Click the start button to start sending data to the server.
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Web Connection Errors
If any error messages display or ServoCommander fails to connect to the server your remote PC may be behind a firewall. In this case disable the firewall on port 81 and repeat. If errors persist you be behind a router and need to enable port forwarding. See your router’s instructions for details on how to enable port forwarding.
Running ServoCommander

Once values are set or loaded click select the Output Device Location and click Start. All mid and end point settings will be locked in while started. If a value is not set the software will not be allowed to start operation and an error message will display. Press stop to return to setup mode to adjust these values if necessary. 

Custom Tab Names

ServoCommander allows for the customization of tabs name. To change a tab name select any channel and click the Edit Tab Name button. Change the name and click save when done. Custom tab names are saved in user profiles.
Reverse at mid

In certain situations it may be useful to allow servo rotation in only one direction from the center point. IE: if a servo was mapped to joystick axis 1, moving the joystick left will rotate the servo left and moving the joystick right will move the servo left.
To enable the reverse at mid function check the Reverse at mid check box within a channel tab. Reverse the channel as necessary.

Hide Label

The ServoCommander logo can be removed to create a smaller footprint. To hide the label, choose Edit (Hide Logo. This function can also be combined with Wide View to create a smaller and wider screen view for small screen PC’s.
Wide View

The ServoCommander logo can be removed to create a smaller footprint. To hide the label, choose Edit (Hide Logo. This function can also be combined with Wide View to create a smaller and wider screen view for small screen PC’s.
Exponential Settings

Setting an exponential rate will vary the amount a servo is moved at a nonlinear proportion to the input method. For example when a joystick axis is moved 10 units a servo will move 10 units. With a certain exponential setting a joystick axis may be moved 10 units will the servo is moved 50 units at the max point.

To set an exponential setting, choose the desired channel tab and click the Exponential button. The exponential settings dialog is displayed like below.
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Exponential Settings Dialog

To set the exponential rate drag the Expo slider to the right. You can set the rate to a specific rate or experiment to obtain the desired result.

You may also set an x offset along with the exponential setting to delay the exponential rates until a certain value is passed.
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